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      CHAPTER 1 

1. Introduction 
The Getting Started Guide provides you with a step by step guide for the 
configuration of the application after installation. As well as provide a number of 
best practices, tips, and suggestions to ensure that product is configured 
effectively for your environment. This guide must be used in conjunction with 
the online help to obtain a completed understanding of the product. It is also 
strongly recommended that the read this whole guide first before attempting 
any of the tasks mentioned. 
 
For further information or to get white papers about some of the topics 
discussed in this document, visit the East River Software Web site at 
http://www.eastriversoftware.com . 
 
Note: All terminology, product references, and recommendations are subject to 
change without notice. 

1.1. Document Conventions 
When installing the ER Management Suite web application, the documentation 
uses the following conventions: 
 
Convention Meaning 

Boldface Italics Commands, names of interface items such as text boxes, 
buttons, and user input fields. 

Italics Placeholders for information or parameters that you 
provide. For example, filename in a procedure means you 
type the actual name of a file. Italics also are used for new 
terms and the titles of books. 

%SystemRoot% The Windows system directory, which can be WTSRV, 
WINNT, WINDOWS, or other name you specify when you 
install Windows. 

Monospace Text displayed in a text file. 

{ braces } A series of items, one of which is required in command 
statements. For example, { yes | no } means you must type 
yes or no. Do not type the braces themselves. 

 This image represents an information tip that you may find 
useful. 

 This image represents some important information that you 
must follow. 
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2. Logging on the First Time 
2.1. Administrator Account  

2.1.1. Database Authentication 
If you have configured ER Management Suite to use database authentication then 
you will need to log in using the following credentials: 

• User Name: ermsadmin 
• Password:  erpassword 

 
  Once you have logged into the application it is strongly recommended that 

you change this password immediately by performing the following steps. 
• Navigate to the following page Home > Profile > Password 
• Enter the following information:  

o Old Password: the existing password 
o New Password: your new password 
o Confirm Password: your new password again 

• Click on the Apply button 

2.1.2. Active Directory Authentication 
If you have configured ER Management Suite to use Active Directory 
authentication then you will need to log in using the following credentials: 

• User Name: ermsadmin 
• Password:  the domain password to the account 

 
  You must have a domain account called “ermsadmin” otherwise you will not 

be able to log on. This account does not require any domain administrative rights. 
 

  Once you have logged into the application can change the logon name for the 
administrator account by performing the following steps. 

• Navigate to the following page Client > Contacts > View/Edit 
• Click the edit  icon for the System Administrator account 
• Click on the Logon tab 
• Enter the following information:  

o User Name: enter the new user name 
• Click on the Apply button 
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3. Configuring the Application Suite 
3.1. Where to Begin 
Before entering any data you must configure the Application suite according to 
your requirements. This involves completing the following three core steps: 

1. Application Settings 
2. Departments and Contacts 
3. Groups and Roles 
4. Application Access 

 
Once you have completed these three steps you are ready to configure each 
application. The configuration steps for each application are discussed in the 
relevant chapters. 

3.2. Application Settings 
By default the ER Management Suite is configured with a number of default 
settings. It is important that you check these settings to ensure that the 
selected options are best suited to your organization. This can be achieved by 
navigating to each of the following pages and confirming that the settings are 
best suited to your environment:  

• Site > Administration > Options > Settings 
• Client > Administration > Options > Settings 
• Home > Administration > Options > Settings 
• Incident > Administration > Options > Settings 
• Project > Administration > Options > Settings 
• To-Do > Administration > Options > Settings 
• Knowledge > Administration > Options > Settings 
• Messaging > Administration > Options > Settings 

 
Refer to the online help as to the meaning of each setting. 

3.3. Departments and Contact 
There are two ways to add departments and contacts into the ERMS: 

1. Importing from Active Directory and 
2. Manual 

3.3.1. Importing from Active Directory 
If have an Active Directory (AD) environment you can import users from AD into 
ERMS by navigating to: 

• Client > Administration > Import/Export > Import Contacts From 
AD 

 
In most cases the user name and password fields will not be required to 
retrieve a list of Active Directory users. Should your Active Directory 
environment not support guest emulation of user accounts, then you must 
supply these credentials. 
 
The import process will import the following attributes from Active Directory. 
The values not in square brackets represent the values as seen in Active 
Directory Users and Computer, while the value inside the square brackets 
represents the LDAP attribute name. 
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AD Attribute ERMS Attribute 

Display Name 
[name] 

Full Name 

User Logon Name 
[sAMAccountName] 

User Name 

First Name 
[givenName] 

First Name 

Last Name 
[sn] 

Last Name 

Department 
[department] 

Department 

Telephone Number 
[telephoneNumber] 

Work Phone 

E-mail 
[Mail] 

E-mail Address 

Mobile 
[mobile] 

Mobile Phone 

Office 
[PhysicalDeliveryOffice] 

Location 

  
  If you unable to connect to Active Directory ensure that your domain value 

is correct in the web.config file. See Active Directory Integration under 
Advanced Topics in the Installation Guide for more information. 
 
As well as import the above attributes into ERMS you must specify the 
language that will be assigned to the imported users. If you have configured 
ERMS for database authentication you must also specify an initial password 
that all imported users will inherit. 

3.3.2. Manually Adding Departments & Contacts 
If you do not have an Active Directory environment you can manually create 
your list of contacts. Start by creating all your departments first, then your 
contacts. 
 
When creating a department you will notice that the Manager field only 
contains the option None. This is because no contacts have been created and 
assigned to the Department Manager role. Once you have completed these 
two steps you can come back and assign a contact to the department as the 
manager.  
 

  Some e-mail rules allow you send an e-mail to the department and/or 
contact manager; this will only occur if the Manager field for the 
department/contact has been set to a contact that has a valid e-mail address.  
 

3.4. Groups and Roles 
Once you have added your list of departments and contacts into ERMS, you 
can then begin to assign users to groups and roles. This step only needs to be 
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performed on those contacts that will log into ERMS. For the purpose of this 
document contacts that have the ability to log into ERMS are referred to as 
Users. 
 
A Group contains both pages and users or just pages. Members of a group 
have access to all the pages that have also been assigned to that group. 
  
A role is very similar to group except that you can only assign users to it. Being 
a member of a role does not give the user access to any pages, instead it 
provides the user with additional functions and/or features with in a page that 
they already have access to. 
 

  The No Access group takes precedents over all other groups.  Any page 
assigned to this group will not be accessible by any user or administrator. The 
Everyone group means any authenticated user. The Guest group means any 
user regardless of authentication. 

3.4.1. Default and Custom Groups 
The Application Suite comes with a number of pre-defined groups that begin 
with “App-“. These groups are not system groups and as such you can edit or 
delete them as you see fit. 
 
These groups represent different functions and roles with the application suite. 
By assigning users to these groups you will give them access to pages that will 
enable them to perform that function/role. The table below describes each of 
these: 
  
Name Comment 

App-Client-Department Manager   Members of this group have access to pages 
that are typically used by departmental 
managers, including the department and 
contact overview pages. 
 

  For completeness members of this group 
should also be a member of the Department 
Manager roles. 

App-Client-Manager   Members of this group have access to pages 
that are typically used by those users who 
need to manage departments and contacts 
with in application suite. 
 

  For completeness members of this group 
should also be a member of the Client 
Manager role. 

App-Home-Calendar-Event-Editor  Members of this group have access to pages 
that allow you to manage calendar events with 
in application suite. 
 

  Normally members of this group would 
also be a member of the App-Home-
Calendar-Owner group.  

App-Home-Calendar-Owner   Members of this group have access to pages 
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that allow you to manage your or your 
buddies’ calendar appointments. 

App-Home-Timesheets-Owner   Members of this group have access to pages 
that allow you to manage your timesheets. 
 

  If you want a user to be able to change 
the timesheet status for all users then add 
them to the Timesheet Manager role. 

App-Incident-Manager   Members of this group have access to pages 
that are typically used by the incident 
managers, including a number of reports. 
 

  For completeness members of this group 
should also be a member of the Incident 
Manager role. 

App-Incident-Owner   Members of this group have access to pages 
that are typically used by the incident owners, 
including viewing and editing incident tickets 
that they are an owner of. 

App-Incident-Resource   Members of this group have access to pages 
that are typically used by incident resources to 
allow them to enter their work notes and times 
for an incident ticket. 
 

  For completeness members of this group 
should also be a member of the Incident 
Resource role. 

App-KC-Article-Approver   Members of this group have access to pages 
that allow them to approve any knowledge 
article that has been created. 
 

  Normally members of this group would 
also be a member of the App-KC-Article-
Editor group, so that they can make editorial 
changes to those articles. 

App-KC-Article-Editor   Members of this group have access to pages 
that allow them to create and edit knowledge 
articles. 

App-KC-Article-Reader   Members of this group have access to pages 
that allow them to search and read knowledge 
articles that they have rights to. 

App-KC-Document-Approver   Members of this group have access to pages 
that allow them to approve new documents for 
publishing. 
 

  It is common for members of this group to 
also be a member of the App-KC-Document 
Folder-Manager group.  
 

  You must also have access and approver 
rights for the document folder to be able to 
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approve documents. This is part of the 
document folder properties.  

App-KC-Document Folder-Creator  Members of this group have access to pages 
that allow them to create, edit and manage 
document folders. 

App-KC-Document Folder-
Manager   

Members of this group have access to pages 
that allow them to manage document folders, 
including the ability to change access and 
approver rights. 

App-KC-Document Folder-
Member   

Members of this group have access to pages 
that allow them to add, edit and download 
documents from document folders that they 
have access to. 

App-MC-Message-Editor   Members of this group have access to pages 
that allow them to create, edit and delete 
messages sent and received from their 
buddies. 

App-MC-Notice-Approver   Members of this group have access to pages 
that allow them to approve any notice that has 
been created. 
 

  Normally members of this group would 
also be a member of the App-MC-Notice-
Editor group, so that they can make editorial 
changes to those notices. 

App-MC-Notice-Editor   Members of this group have access to pages 
that allow them to create and edit notices. 

App-MC-Notice-Reader   Members of this group have access to pages 
that allow them to search and read notices 
that they have rights to. 

App-Project-Manager   Members of this group have access to pages 
that are typically used by project managers, 
including a number of reports. 
 

  For completeness members of this group 
should also be a member of the Project 
Manager role. 

App-Project-Owner   Members of this group have access to pages 
that are typically used by the project owners 
to view the status of projects that they are an 
owner of. 

App-Project-Resource   Members of this group have access to pages 
that are typically used by project resources to 
allow then to enter their work notes and times. 
 

  For completeness members of this group 
should also be a member of the Project 
Resource role. 

App-ToDo-List-Creator   Members of this group have access to pages 
that allow then to create, edit and delete task 
lists. 
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App-ToDo-List-Member   Members of this group have access to pages 
that are allow list members to enter their work 
notes and times against a tasks with in a list 
that they have access to. 

App-ToDo-Task-Owner Members of this group have access to pages 
that are typically used by the task owners to 
view the status of tasks that they are an 
owner of. 

3.4.2. Assigning Pages to Groups 
You can only assign pages to groups that are of the type Page Only or Both. 
Such groups will have the assign page  icon next to their name, click on this 
icon to assign pages to the group.  
 

  Any pages assigned to the Everyone group means that all authenticated 
users will have access to these pages. While pages assigned to the Guest 
group means any user regardless if they are authenticated or not, will have 
access to these pages. 

3.4.3. Assigning Users to Groups 
You can only assign contacts to groups that are of the type Contact Only or 
Both. Such groups will have the assign contact  icon next to their name, click 
on this icon to assign users to the group. By assigning a user to a group, they 
will then have access to any pages that has also been assigned to that group.   

3.4.4. Assigning Users to Roles 
Roles will only have the assign contact  icon next to their name allowing you 
to only assign users to them. Roles can not have any pages assigned to them, 
rather roles provided the user with additional functions/features in existing 
pages that they already have access to. 

3.4.5. Reloading the Cache and Rebuilding the Menu 

  After you have completed assigning the pages and/or contacts to the 
groups and roles you must refresh the cache to ensure that all changes can be 
seen. This can be done by going to the page: 

• Site > Administration > Options > Reload Cache 
 
Once you have reloaded the cache, it is also important to force the rebuilding of 
all menus. This can be done by going to the page: 

• Site > Tab/Menu > Rebuild Menu 
 

3.5. Application Security 
In the previous section we look at assigning pages to groups, in effect what we 
were doing was configuring page level security. In this section we look at 
application level security.   
 
Application level security takes precedents over page level security. This 
means that if you do not have access to the application, then you also do not 
have any access to pages within that application.  
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3.5.1. Application Access Rights 
To set the application access rights navigate to the following page 

• Site > Applications > View/Edit 
 
View/Edit page displays the access rights associated with each application. 
You should review these to ensure that they are correct for your environment. If 
you wish to make changes click on the edit  icon for the application that you 
want to make the changes to. 
 

  We DO NOT recommended that you change the access rights associated 
with the Home and Log Off applications. 

3.5.2. Reloading the Cache and Rebuilding the Menu 

  After you have completed changing the application access rights you must 
refresh the cache to ensure that all changes can be seen. This can be done by 
going to the page: 

• Site > Administration > Options > Reload Cache 
 
Once you have reloaded the cache, it is also important to force the rebuilding of 
all menus. This can be done by going to the page: 

• Site > Tab/Menu > Rebuild Menu 
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4. Home Application 
4.1. Time Management  
The Home application is responsible for providing the Time Management 
functionality that is used through out the suite of applications. In this section we 
look at how to configure the Time Management functionality. 

4.1.1. Ticket and Task Integration 
By default Incident Tickets, Project Tasks and To-Do Tasks have all been 
configured so that they appear in any of the Timesheets (including the Quick 
Entry, Simple and Advanced). 
 
This is configured as follows: 

• A Home status (see Home > Administration > Statuses > 
View/Edit) has been created with the Track Time option enabled 
for each object (Incident Ticket, Project Task or To-Do Task). 

• Through the Home > Administration > Options > Settings page 
this status is then assigned to the corresponding status. 

 
The end effect of this configuration means that the name of the status will be 
prefixed to the title/subject. Under the default settings this will be: 

• TK – for Incident Tickets 
• PR – for Project Tasks 
• TD – for To-Do Tasks 

 
  You change the name of the status or assigned a different status to each of 

these objects if you wish using the above two mentioned pages. 

4.1.2. Incident, Project and To-Do Integration 
In previous section we looked at how to get Incident Tickets, Project Tasks or 
To-Do Tasks to appear as a task in our timesheets. But what if we want to 
enter our times directly in each application and still see those times in our 
timesheets (i.e. Advanced).  
 
For this to occur we need to ensure that the Timesheet Integration option has 
been enabled for each application. This can be done by navigating to the 
following pages: 

• Incident > Administration > Options > Settings 
• Project > Administration > Options > Settings 
• To-Do > Administration > Options > Settings 

 
When set to Yes, times entered through the Notes page will also appear in the 
timesheets. 

4.2. Statuses 
Home statues appear in the list of tasks for timesheets, but also represent your 
status in the buddy status web part. In other words when switching your 
timesheet status, you are also updating your status in the buddy status web 
part. 
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4.2.1. Default and Custom Statues 
You should review the existing statuses by navigating to the Home > 
Administration > Statuses > View/Edit page. If you want to change any of the 
properties click on the edit  icon. The statues that are shipped as part of the 
product can not be deleted; however you can disable them by changing the 
access rights. Use the Home > Administration > Statuses > New page to add 
your own custom status. Refer to the online help for more information. 
 

  The status name is a translated string, therefore if the string does not exist 
you must create it by navigating to the Site > Languages >View/Edit page; 
then click on the add string  icon. See Site Application later in this guide for 
more information as well as the online help. 

4.2.2. Track Time Option 
If a home status has the Track Time option enabled, then you can add work 
notes and times against that status. This type of status has a dual purpose: 

1. Track your time and work notes 
2. Change your status in the buddy status web part 

 
If the Track Time option is not enabled, then you can not track any time for that 
status and the status has the only purpose of changing your status in the buddy 
status web part. 

4.3. Buddy Management 
Buddy Management allows users to share information that they own with their 
buddies, this includes: 
• Messaging  
• Buddy Status  
• Calendar  
• Ticket 
 
User can share their information through the following two pages: 

• Home > Buddies > Who Are My Buddies? – Determines what 
level of access you wish to give another user. 

• Home > Buddies > Which Buddies Can I See? – Determines 
which buddies (who have given you access) you actually wish to 
see. 

 
As can be seen above to see another users Tickets (for example) is a two step 
process: 

1. They must give you rights to view their tickets through the page 
Home > Buddies > Who Are My Buddies? 

2. Once they have given you rights, you must select there name 
through the page Home > Buddies > Which Buddies Can I 
See? Otherwise you will not see any of there tickets. 

 

  The page Home > Buddies > Buddy Management is only intended for 
administrators and Client Managers as this allows you to change any users 
buddy preferences. 
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5. Incident Management 
5.1. Statuses 
Statues allow you to set the current point that the incident ticket is at. 

5.1.1. Default and Custom Statues 
You should review the existing statuses by navigating to the Incident > 
Administration > Statuses > View/Edit page. If you want to change any of the 
properties click on the edit  icon. The statues that are shipped as part of the 
product can not be deleted; however you can disable them by changing the 
access rights. Use the Incident > Administration > Statuses > New page to 
add your own custom status. Refer to the online help for more information. 
 

  The status name is a translated string, therefore if the string does not exist you 
must create it by navigating to the Site > Languages >View/Edit page; then click 
on the add string  icon. See Site Application later in this guide for more 
information as well as the online help. 

5.1.2. Closed Status 
Once you have defined all your statues you must assign a status as the one 
that will represent closed tickets. This can be done through the Incident > 
Administration > Options > Settings page. See the online help for more 
information. 
 

  It is not recommended that you change this option once incident tickets 
have been created. By changing this value tickets that were previously closed 
will become open again. 

5.2. Priorities 
Priorities allow you to set a level of importance for the incident ticket. 

5.2.1. Default and Custom Priorities 
You should review the existing priorities by navigating to the Incident > 
Administration > Priorities > View/Edit page. If you want to change any of 
the properties click on the edit  icon. The priorities that are shipped as part of 
the product can not be deleted; however you can disable them by changing the 
access rights. Use the Incident > Administration > Priorities > New page to 
add your own custom priority. Refer to the online help for more information 
 

  The priority name is a translated string, therefore if the string does not exist 
you must create it by navigating to the Site > Languages >View/Edit page; 
then click on the add string  icon. See Site Application later in this guide for 
more information as well as the online help. 

5.3. Categories and Sub-Categories 
Categories and sub-categories allow you to classify your incident tickets. 

5.3.1. Default and Custom Categories 
You should review the existing categories by navigating to the Incident > 
Administration > Categories > View/Edit page. If you want to change any of 
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the properties click on the edit  icon. Use the Incident > Administration > 
Categories > New page to add your own custom category. Refer to the online 
help for more information. 

5.3.2. Sub-Categories 
Once you have created all your categories you can create one or more sub-
categories by navigating to Incident > Administration > Sub-Categories > 
New page.  
 

  The category and sub-category name is a translated string, therefore if the 
string does not exist you must create it by navigating to the Site > Languages 
>View/Edit page; then click on the add string  icon. See Site Application later 
in this guide for more information as well as the online help. 

5.4. Templates 
Templates allow you to create a new incident ticket with pre-populated 
information in one or more fields. This can save your incident resource a 
significant amount of time when creating tickets for issues that are common 
and quickly resolved. 

5.4.1. Default and Custom Templates 
You should review the existing templates by navigating to the Incident > 
Administration > Templates > View/Edit page. If you want to change any of 
the properties click on the edit  icon. Use the Incident > Administration > 
Templates > New page to add your own custom template. Refer to the online 
help for more information. 

5.4.2. Standard Template 
A new ticket is always based on the standard template when no other template 
is selected. This includes when creating a new ticket by navigating to the page 
Incident > Tickets > New. The standard template can not be deleted.  

5.5. Routes 
Routes are automatic rules that you can create. These rules will assign a ticket 
to the most appropriate resource based on the category and priority that has 
been assigned to the ticket. 

5.5.1. Default and Custom Routing Rules 
You should review the existing routing rules by navigating to the Incident > 
Administration > Routes > View/Edit page. The default routing rule should be 
changed so that tickets are assigned to the correct resource. You can do this 
by clicking on the edit  icon. This rule can not be deleted and can only be 
disabled if there is as least one other rule that is enabled. One routing rule must 
be enabled at all times. 
 
Use the Incident > Administration > Routes > New page to add your own 
custom route. Refer to the online help for more information. 

5.5.2. How It Works 
When a ticket is submitted with the option Use Routing Rules it is then 
compared against the routing rules, the first rule that matches the criteria is 
then used to determine who the ticket should be assigned to. 
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Routing rules are process in order from lowest to highest. In other words a rule 
with an order of 1 will be process before a rule with an order of 99. 
 

  It is important to have a catch all routing rule (any category and any 
priority) otherwise tickets may not be assigned to a valid resource. 

5.6. E-mail Rules 
E-mail rules allow you to automatically send an e-mail when an incident ticket is 
saved or updated. The e-mail is sent when the action and the contact making 
that action; matches one or more rules.  

5.6.1. Default and Custom E-mail Rules 
You should review the existing e-mail rules by navigating to the Incident > 
Administration > E-mail > View/Edit page. The default e-mail rules should not 
be deleted, however you can enabled and disable them as you see fit. Do this 
by clicking on the edit  icon. Use the Incident > Administration > E-mail > 
New page to add your own custom rule. Refer to the online help for more 
information. 
 

  It is important that you have configured the e-mail server name and 
enabled e-mail function for the whole site. Navigate to the page Site > 
Administration > Options > Settings and verify that these settings are 
correct. Use the page Site > Administration > Options > Test E-mail page to 
test the settings. Refer to the online help for more information. 
 

  The name of an e-mail rule is a translated string, therefore if the string does 
not exist you must create it by navigating to the Site > Languages >View/Edit 
page; then click on the add string  icon. See Site Application later in this guide 
for more information as well as the online help. 
 

  Give careful consideration to the rules that you create. Test and validate 
your rules as the application does not prevent a recipient from receiving 
multiple e-mails because they have matched multiple rules. You may want to 
consider creating separate e-mail rules for each class of recipient.  

5.6.2. How It Works 
After a ticket has been saved or updated it is then compared against the e-mail 
rules that are enabled. Rules that match the criteria are then sent to the 
selected recipients. If the Review option is set to Yes then the user will have 
the ability to review and edit the e-mail prior to it being sent. 
 
E-mail rules are process in order from lowest to highest. In other words a rule 
with an order of 1 will be process before a rule with an order of 99. Remember, 
all enabled e-mail rules are processed. 
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6. Project Management 
6.1. Statuses 
Statues allow setting the current point that the project or project task is at. 

6.1.1. Default and Custom Statues 
You should review the existing statuses by navigating to the Project > 
Administration > Statuses > View/Edit page. If you want to change any of the 
properties click on the edit  icon. The statues that are shipped as part of the 
product can not be deleted; however you can disable them by changing the 
access rights. Use the Project > Administration > Statuses > New page to 
add your own custom status. Refer to the online help for more information. 
 

  The status name is a translated string, therefore if the string does not exist 
you must create it by navigating to the Site > Languages >View/Edit page; 
then click on the add string  icon. See Site Application later in this guide for 
more information as well as the online help. 

6.1.2. Closed and Completed Status 
Once you have defined all your statues you must assign a status as the one 
that will represent closed projects and completed tasks. This can be done 
through the Project > Administration > Options > Settings page. See the 
online help for more information. 
 

  It is not recommended that you change these options once projects and 
tasks have been created. Changing this value after data has been entered, will 
force those project or project tasks to become open again. 

6.2. Priorities 
Priorities allow you to set a level of importance for the project. 

6.2.1. Default and Custom Priorities 
You should review the existing priorities by navigating to the Project > 
Administration > Priorities > View/Edit page. If you want to change any of 
the properties click on the edit  icon. Use the Project > Administration > 
Priorities > New page to add your own custom priority. Refer to the online help 
for more information 
 

  The priority name is a translated string, therefore if the string does not exist 
you must create it by navigating to the Site > Languages >View/Edit page; 
then click on the add string  icon. See Site Application later in this guide for 
more information as well as the online help. 

6.3. Categories  
Categories allow you to classify your projects. 

6.3.1. Default and Custom Categories 
You should review the existing categories by navigating to the Project > 
Administration > Categories > View/Edit page. If you want to change any of 
the properties click on the edit  icon. Use the Project > Administration > 
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Categories > New page to add your own custom category. Refer to the online 
help for more information. 
 

  The category name is a translated string, therefore if the string does not 
exist you must create it by navigating to the Site > Languages >View/Edit 
page; then click on the add string  icon. See Site Application later in this guide 
for more information as well as the online help. 

6.4. Cost Types 
Cost Types allow you to define different cost categories that can be assigned to 
your projects. 

6.4.1. Default and Custom Cost Types 
You should review the existing cost types by navigating to the Project > 
Administration > Cost Type > View/Edit page. If you want to change any of 
the properties click on the edit  icon. The cost types that are shipped as part 
of the product can not be deleted; however you can disable them by changing 
the access rights. Use the Project > Administration > Cost Type > New page 
to add your own custom cost type. Refer to the online help for more 
information. 
 

  The cost type name is a translated string, therefore if the string does not 
exist you must create it by navigating to the Site > Languages >View/Edit 
page; then click on the add string  icon. See Site Application later in this guide 
for more information as well as the online help. 

6.5. E-mail Rules 
E-mail rules allow you to automatically send an e-mail when a project or project 
task is saved or updated. The e-mail is sent when the action and the contact 
making that action; matches one or more rules.  

6.5.1. Default and Custom E-mail Rules 
You should review the existing e-mail rules by navigating to the Project > 
Administration > E-mail > View/Edit page. The default e-mail rules should not 
be deleted, however you can enabled and disable them as you see fit. Do this 
by clicking on the edit  icon. Use the Project > Administration > E-mail > 
New page to add your own custom rule. Refer to the online help for more 
information. 
 

  It is important that you have configured the e-mail server name and 
enabled e-mail function for the whole site. Navigate to the page Site > 
Administration > Options > Settings and verify that these settings are 
correct. Use the page Site > Administration > Options > Test E-mail page to 
test the settings. Refer to the online help for more information. 
 

  The name of an e-mail rule is a translated string, therefore if the string does 
not exist you must create it by navigating to the Site > Languages >View/Edit 
page; then click on the add string  icon. See Site Application later in this guide 
for more information as well as the online help. 
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  Give careful consideration to the rules that you create. Test and validate 
your rules as the application does not prevent a recipient from receiving 
multiple e-mails because they have matched multiple rules. You may want to 
consider creating separate e-mail rules for each class of recipient.  

6.5.2. How It Works 
After the project or project task has been saved or updated it is then compared 
against the e-mail rules that are enabled. Rules that match the criteria are then 
sent to the selected recipients. If the Review option is set to Yes then the user 
will have the ability to review and edit the e-mail prior to it being sent. 
 
E-mail rules are process in order from lowest to highest. In other words a rule 
with an order of 1 will be process before a rule with an order of 99. Remember, 
all enabled e-mail rules are processed. 
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7. To-Do Application 
7.1. Statuses 
Statues allow setting the current point that the task is at. 

7.1.1. Default and Custom Statues 
You should review the existing statuses by navigating to the To-Do > 
Administration > Statuses > View/Edit page. If you want to change any of the 
properties click on the edit  icon. The statues that are shipped as part of the 
product can not be deleted; however you can disable them by changing the 
access rights. Use the To-Do > Administration > Statuses > New page to 
add your own custom status. Refer to the online help for more information. 
 

  The status name is a translated string, therefore if the string does not exist 
you must create it by navigating to the Site > Languages >View/Edit page; 
then click on the add string  icon. See Site Application later in this guide for 
more information as well as the online help. 

7.1.2. Completed Status 
Once you have defined all your statues you must assign a status as the one 
that will represent completed tasks. This can be done through the To-Do > 
Administration > Options > Settings page. See the online help for more 
information. 
 

  It is not recommended that you change this option once tasks have been 
created. By changing this value tasks that were previously completed will 
become open again. 

7.2. Priorities 
Priorities allow you to set a level of importance for the task. 

7.2.1. Default and Custom Priorities 
You should review the existing priorities by navigating to the To-Do > 
Administration > Priorities > View/Edit page. If you want to change any of 
the properties click on the edit  icon. Use the To-Do > Administration > 
Priorities > New page to add your own custom priority. Refer to the online help 
for more information 
 

  The priority name is a translated string, therefore if the string does not exist 
you must create it by navigating to the Site > Languages >View/Edit page; 
then click on the add string  icon. See Site Application later in this guide for 
more information as well as the online help. 

7.3. E-mail Rules 
E-mail rules allow you to automatically send an e-mail when a task is saved or 
updated. The e-mail is sent when the action and the contact making that action; 
matches one or more rules.  
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7.3.1. Default and Custom E-mail Rules 
You should review the existing e-mail rules by navigating to the To-Do > 
Administration > E-mail > View/Edit page. The default e-mail rules should not 
be deleted, however you can enabled and disable them as you see fit. Do this 
by clicking on the edit  icon. Use the To-Do > Administration > E-mail > 
New page to add your own custom rule. Refer to the online help for more 
information. 
 

  It is important that you have configured the e-mail server name and 
enabled e-mail function for the whole site. Navigate to the page Site > 
Administration > Options > Settings and verify that these settings are 
correct. Use the page Site > Administration > Options > Test E-mail page to 
test the settings. Refer to the online help for more information. 
 

  The name of an e-mail rule is a translated string, therefore if the string does 
not exist you must create it by navigating to the Site > Languages >View/Edit 
page; then click on the add string  icon. See Site Application later in this guide 
for more information as well as the online help. 
 

  Give careful consideration to the rules that you create. Test and validate 
your rules as the application does not prevent a recipient from receiving 
multiple e-mails because they have matched multiple rules. You may want to 
consider creating separate e-mail rules for each class of recipient.  

7.3.2. How It Works 
After the task has been saved or updated it is then compared against the e-mail 
rules that are enabled. Rules that match the criteria are then sent to the 
selected recipients. If the Review option is set to Yes then the user will have 
the ability to review and edit the e-mail prior to it being sent. 
 
E-mail rules are process in order from lowest to highest. In other words a rule 
with an order of 1 will be process before a rule with an order of 99. Remember, 
all enabled e-mail rules are processed. 
 
 
 
 
 

 
Getting Started – To-Do Application  19 

https://www.loquinar.com.au/ERMS/_Modules/Site/add_Site_LangString.aspx?id=1�


      CHAPTER 8 

8. Site Application 
8.1. Defining a Custom Language 

8.1.1. Adding a Custom Language 
ER Management Suite has been developed to support multiple languages, 
however at this stage only English – US is shipped with the product. You can 
add define you own language by using the process. 

1. Create the Language – Navigate to the page Site > Languages 
> New and add your new language. Refer to the online help for 
information about the different fields 

2. Export the English – US language – Navigate to the page Site 
> Administration > Import/Export > Export Language and 
export the English – US language. Download this file to your local 
machine. 

3. Edit the Language File – Use notepad (or any text editor) to 
modify the downloaded language file.  See Language File Format 
below for more information. 

4. Import Your String – Navigate to the page Site > 
Administration > Import/Export > Import Language and import 
the file that you have just modified. Ensure that you have 
selected your new language. 

8.1.2. Language File Format 
The language file that you have downloaded is made up of the following parts 

• Cache – determines if the string should be cached 
• Value – This is the internal name of the string. Do not change this 

value  
• Text – The translated value of the string. You should modify this 

string part to your chosen language. 
 
Each of these parts is separated by the = sign. Do not use the = sign for any 
part of the value or text. 

8.2. Defining a Custom String 
Certain fields through out the suite use translated values, this will often mean 
that you must add a string to all enabled languages, otherwise the value will be 
display untranslated, with the @ symbol pre and post fixed to the word. 

8.2.1. Adding a Custom String 
To add a custom string navigate to the Site > Languages > View/Edit page 
and click on the add string  icon. 

• Value – This is the name of the value that you previously entered.  
• Cache – Check this option if you want the string to be cache. 
• Text – The translated value of the string. 

Click the OK button to save you new string. 
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9. Client Management 
9.1. Asset Management 
Asset management allows you define an asset type, create assets based on 
that type, then assign assets to other objects such as incident tickets, projects 
and to-do tasks. There are three steps to creating an asset; 

1. Define one or more asset fields. An asset field captures one piece of 
information. An example of this is a serial number or the brand name.  

2. Define an asset type by grouping one or more asset fields 
3. Define a new asset based on an asset type 

9.1.1. Categories  
Categories allow you to classify your asset types. For example Hardware and 
Software would be type types of categories. 
 
You should start by navigating to the Client > Assets > Categories > New 
Category page and add your own categories.  
 

  The category name is a translated string, therefore if the string does not 
exist you must create it by navigating to the Site > Languages >View/Edit 
page; then click on the add string  icon. See Site Application later in this guide 
for more information as well as the online help. 

9.1.2. Asset Field 
As mentioned previously before you can add a new asset you must begin by 
defining one or more asset fields that will capture information about the asset. 
 
An asset field can be based on one of the following field types: 

• Textbox – that allows the user to enter any text in a single line 
rectangular input box 

• Multi-line textbox - that allows the user to enter any text on multiple 
lines in a square input box 

• Checkbox List - A checkbox control displays one or more items, each 
item can be either checked or unchecked.  

• Date - This control allows the selection of a date from a pick list or 
through manual entry.  

• Dropdown List - Displays one or more items (that you define) in a drop-
down menu, but only one single item can be selected from the list.  

• Listbox - A list box control displays and allows you to select one or 
more items that you define.  

• Radio List - A radio control displays one or more items, but only one 
item can be selected at a time.  

 
To begin navigate to the Client > Assets > Fields > New page and select the 
type of field that you wish to create. Enter the name for this field, then 
depending on the field type that you select you may be required to enter 
additional information.  

• Max Length - This controls the maximum length of text that is entered. 
For lists (checkbox, dropdown, list box and radio) a value greater than 
zero restricts the number of characters for a list item that is entered. For 
textboxes a value greater than zero restricts the number of characters 
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that can be entered. A value of zero means that there is no restriction in 
the amount of text that can be typed.   

• Local Data - Only applies to list controls (checkbox, dropdown, list box 
and radio). If set to No then you can add, edit and remove list items for 
this field at this point. When the field is assigned to an asset type you 
will also inherit this list of items. If set to Yes then the above options are 
not available. Instead, list items are entered when the field is added to 
an asset type, allowing different list items to be added for each asset 
type that the field is assigned to.   

 
You must repeat this process for each piece of information that you want to 
capture about the asset. 
 

  For simplicity and easy management it is recommended that you have 
unique names for each asset field.  

9.1.3. Asset Type 
Once you have defined your asset fields, you must group them to create an 
asset type. Or another way to put it; an asset type is a collection of one or more 
asset fields. 
 
Begin by navigating to the Client > Assets > Types > New page, enter the 
following mandatory information; 

• Name - a unique name for this asset type 
• Category – the classification for the asset type 
• Access Rights – Who has access to assets of this type 
• Fields – select one or more fields to assign to this asset type. Refer to 

the online help for more information.  

9.1.4. Assets 
It is at stage that you are ready to add a new asset by navigating to the Client 
> Assets > New page. Select the type of asset that this is and then enter the 
required information. 

9.2. E-mail Rules 
E-mail rules allow you to automatically send an e-mail when a Note is saved or 
updated for a contact or department. The e-mail is sent when the action and 
the contact making that action; matches one or more rules.  

9.2.1. Default and Custom E-mail Rules 
You should review the existing e-mail rules by navigating to the Client > 
Administration > E-mail > View/Edit page. The default e-mail rules should not 
be deleted, however you can enabled and disable them as you see fit. Do this 
by clicking on the edit  icon. Use the Client > Administration > E-mail > 
New page to add your own custom rule. Refer to the online help for more 
information. 
 

  It is important that you have configured the e-mail server name and 
enabled e-mail function for the whole site. Navigate to the page Site > 
Administration > Options > Settings and verify that these settings are 
correct. Use the page Site > Administration > Options > Test E-mail page to 
test the settings. Refer to the online help for more information. 
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  The name of an e-mail rule is a translated string, therefore if the string does 

not exist you must create it by navigating to the Site > Languages >View/Edit 
page; then click on the add string  icon. See Site Application later in this guide 
for more information as well as the online help. 
 

  Give careful consideration to the rules that you create. Test and validate 
your rules as the application does not prevent a recipient from receiving 
multiple e-mails because they have matched multiple rules. You may want to 
consider creating separate e-mail rules for each class of recipient.  

9.2.2. How It Works 
After the note has been saved or updated it is then compared against the e-
mail rules that are enabled. Rules that match the criteria are then sent to the 
selected recipients. If the Review option is set to Yes then the user will have 
the ability to review and edit the e-mail prior to it being sent. 
 
E-mail rules are process in order from lowest to highest. In other words a rule 
with an order of 1 will be process before a rule with an order of 99. Remember, 
all enabled e-mail rules are processed. 
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10. Knowledge Center 
10.1. Document Folders 
Document folders allow you to upload and save documents with the suite of 
applications. The Knowledge Center is responsible for providing all other 
applications with the ability to upload and save documents. This includes the 
Incident, Project and Client applications.  

10.1.1. How It Works 
Documents folder are simply a file path either on the web server itself or on a 
network share. When a user uploads a file the file is saved to that file path.  
 
File Permissions 
Because the file system is used to save files (rather than the database) it is 
important that the web server has permissions to that location. Specifically it is 
the account that is used by the application pool that will require rights. 
If your application pool is configured to use a Windows account then the file 
permissions (and share permissions) must be granted to that account. If your 
application pool is using the Windows Network account, then you can assign 
the server account to the file and share permissions.  
 

  Incorrect permissions are a common cause as to why documents can not 
be uploaded. 

10.1.2. Integration Support 
All document folders that are created can be viewed through the Knowledge > 
Documents > View/Edit page provided that you have rights to that document 
folder. Document folders are automatically created for each integrated 
application (Incident, Projects and Client) when the Documents tab is clicked 
on for the first time. Incident and Project document folders are created as 
hidden folders by default (this can not be changed) and do not appear in the list 
unless you click on the Show Hidden option. 

10.1.3. Folder Locations 
By default the Document Folder setting for each application will determine 
where the folder is created. Incident and Project document folders are named 
according to the ticket and project identifiers (ids). The Client application has 
the Document Default Name setting that allows you to determine if the full 
name (of the contact or department) is used instead of the identifier. 

10.1.4. Security 
Access to the document folder is maintained by the application users will only 
see document folders that they have rights to. Security is based on the whole 
document folder and as such there is no support for security on individual 
documents. 
 

  The Document Folder path should never be set to a location that can be 
navigated to via a URL. 
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10.1.5. Approver 
As part of the Document Folder properties you can set a user or a group of 
users as an approver. The approver must then approve a new document before 
it is published (visible) to everyone else. However, if you do not want a formal 
approval process, then select the Everyone group. By selecting the Everyone 
group uploaded documents become self approving. 

10.2. E-mail Rules 
E-mail rules allow you to automatically send an e-mail when an article is saved 
or updated. The e-mail is sent when the action and the contact making that 
action; matches one or more rules.  

10.2.1. Default and Custom E-mail Rules 
You should review the existing e-mail rules by navigating to the Knowledge > 
Administration > E-mail > View/Edit page. The default e-mail rules should not 
be deleted, however you can enabled and disable them as you see fit. Do this 
by clicking on the edit  icon. Use the Knowledge > Administration > E-mail 
> New page to add your own custom rule. Refer to the online help for more 
information. 
 

  It is important that you have configured the e-mail server name and 
enabled e-mail function for the whole site. Navigate to the page Site > 
Administration > Options > Settings and verify that these settings are 
correct. Use the page Site > Administration > Options > Test E-mail page to 
test the settings. Refer to the online help for more information. 
 

  The name of an e-mail rule is a translated string, therefore if the string does 
not exist you must create it by navigating to the Site > Languages >View/Edit 
page; then click on the add string  icon. See Site Application later in this guide 
for more information as well as the online help. 
 

  Give careful consideration to the rules that you create. Test and validate 
your rules as the application does not prevent a recipient from receiving 
multiple e-mails because they have matched multiple rules. You may want to 
consider creating separate e-mail rules for each class of recipient.  

10.2.2. How It Works 
After the article has been saved or updated it is then compared against the e-
mail rules that are enabled. Rules that match the criteria are then sent to the 
selected recipients. If the Review option is set to Yes then the user will have 
the ability to review and edit the e-mail prior to it being sent. 
 
E-mail rules are process in order from lowest to highest. In other words a rule 
with an order of 1 will be process before a rule with an order of 99. Remember, 
all enabled e-mail rules are processed. 
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      CHAPTER 11 

11. Messaging Application 
11.1. Notices 
Notices allow you to publish a message that can viewed by users.  

11.1.1. External Notices 
For a notice to appear on the log on page, the Access Rights must set to 
guest. This is because contacts that visit the log on page are not 
authenticated, until they type in their credentials and click on the Submit 
button. 

11.1.2. Internal Notices 
Notices that have not been set to guest will appear only to authenticated users 
on the Home > Dashboard page, provided that the user has rights to the 
notice.   

11.1.3. Sticky Option 
A user can get rid of a notice by clicking on the acknowledge  icon, however if 
the sticky option is set to Yes then the notice will not disappear even if the user 
click on the acknowledge icon. 

11.2. Messages 
Messages are a simple way of sending a short message to buddy. These 
messages appear on the left hand side above the menu. 

11.2.1. Before You Send a Message 
To be able to send a buddy a message you ensure that the following two tasks 
have been completed: 

5. Your buddy must give you rights to allow you to send them a 
message, this is done through the page Home > Buddies > Who 
Are My Buddies? 

6. Once they have given you rights, you must select their name 
through the Home > Buddies > Which Buddies Can I See? 
Page. Otherwise you will not see their name in your list. 

 
  This function is only intended for short messages as large messages may 

distort the display of the web page. 

11.3. E-mail Rules 
E-mail rules allow you to automatically send an e-mail when a notice is saved 
or updated. The e-mail is sent when the action and the contact making that 
action; matches one or more rules.  

11.3.1. Default and Custom E-mail Rules 
You should review the existing e-mail rules by navigating to the Messaging > 
Administration > E-mail > View/Edit page. The default e-mail rules should not 
be deleted, however you can enabled and disable them as you see fit. Do this 
by clicking on the edit  icon. Use the Messaging > Administration > E-mail 
> New page to add your own custom rule. Refer to the online help for more 
information. 
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  It is important that you have configured the e-mail server name and 
enabled e-mail function for the whole site. Navigate to the page Site > 
Administration > Options > Settings and verify that these settings are 
correct. Use the page Site > Administration > Options > Test E-mail page to 
test the settings. Refer to the online help for more information. 
 

  The name of an e-mail rule is a translated string, therefore if the string does 
not exist you must create it by navigating to the Site > Languages >View/Edit 
page; then click on the add string  icon. See Site Application later in this guide 
for more information as well as the online help. 
 

  Give careful consideration to the rules that you create. Test and validate 
your rules as the application does not prevent a recipient from receiving 
multiple e-mails because they have matched multiple rules. You may want to 
consider creating separate e-mail rules for each class of recipient.  

11.3.2. How It Works 
After the notice has been saved or updated it is then compared against the e-
mail rules that are enabled. Rules that match the criteria are then sent to the 
selected recipients. If the Review option is set to Yes then the user will have 
the ability to review and edit the e-mail prior to it being sent. 
 
E-mail rules are process in order from lowest to highest. In other words a rule 
with an order of 1 will be process before a rule with an order of 99. Remember, 
all enabled e-mail rules are processed. 
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